티스토리 뷰

에러

brown@brown-dev:~$ sudo apt install npm
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다       
상태 정보를 읽는 중입니다... 완료
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
 npm : 의존: node-gyp (>= 0.10.9) 하지만 %s 패키지를 설치하지 않을 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.

해결법

위와 같이 패키지 의존성으로 인하여 설치가 되지 않는 경우 아래와 같은 방법으로 해결 할 수 있음

sudo apt-get install nodejs-dev node-gyp libssl1.0-dev

위 패키지를 설치 후 다시 npm 설치

sudo apt-get install npm

주의사항

libcurl4-oppenssl-dev, libssl-dev 패키지가 설치할 때 제거됨

Comments
댓글쓰기 폼